Ubuntu 14.04 Server upgrade error

You have Debian repository in your source list (ftp.us.debian.org…) which
is causing this problem.

The latest version of locales available in Ubuntu 14.04 Repository
is already installed on your
system. Also this package has no file
which will replace
/usr/sbin/validlocale

So removing this Debian repository from /etc/apt/sources.list should solve
your problem.

After editing the sources.list don’t forget to execute the following
command.

sudo apt-get clean
sudo apt-get update

*Or*

*(Not recommended as it can destroy your system)*

You can overwrite this file using following command

sudo apt-get -o Dpkg::Options::=”–force-overwrite” install locales

Here old /usr/sbin/validlocale from libc-bin will be overwritten by new one
from locales.

Revisions

No comments yet.

Leave a Reply